Hyper-V Remote Management Configuration Utility (HVRemote)

HVRemote reduces the manual configuration steps needed for Hyper-V Remote Management down to a few simple commands, and can diagnose common configuration errors.

 
 
 
 
 
4.7 Star
(125)
Add to favorites
10/24/2016
E-mail Twitter del.icio.us Digg Facebook
Sign in to ask a question


  • Please PLEASE update this for Windows 10 RTM
    1 Posts | Last post July 31, 2015
    • I've been using this tool in a workgroup environment.
      
      Sadly I've updated some clients to Window 10 RTM (Pro) and now they can't access Hyper-V 2012 R2 on a workgroup server....
      
      I've tried EVERYTHING, even managed to configure CredSSP on client and server, only to received the error "Cannot use this version of Hyper-V Manager to manage Windows Server 2012 or Windows Server 2012 R2 as a different user".
      
      
      I could at least use a clue as to where the problem may reside, as
      
      cscript hvremote.wsf /override /show /target:<target-workgroup-server> 
      
      yields no error, same from the server.
      
      
      Again, my config is workgroup environment, Windows 10 clients to Windows Server 2012 R2 Hyper-V. All Windows 8 and 8.1 clients connect normally.
  • FAILOVER CLUSTER? Has this been used on HyperV Failover cluster environments?
    1 Posts | Last post January 08, 2015
    • We are currently running 2012 HyperV Failover cluster (just 2 servers at the moment). Will be moving to 2012R2 HyperV failover cluster with 3 servers soon, but would like to know if this would work in this type of setup?
      
  • Cannot connect to root\cimv2
    3 Posts | Last post December 26, 2014
    • Hi, John
      
      I want to use Hyper-V manager on Windows Server 2008R2 to manager a Hyper-V Server 2008R2. But always failed after I tried all the steps in hvremote document. Need your help!
      
      Client - Windows Server 2008R2
      
      -------------------------------------------------------------------------------
      Stored Credentials
      -------------------------------------------------------------------------------
      
      
      Currently stored credentials:
      
          Target: Domain:target=IOALAB-X1
          Type: Domain Password
          User: IOALAB-X1\david
      
      
      
      -------------------------------------------------------------------------------
      Testing connectivity to server:IOALAB-X1
      -------------------------------------------------------------------------------
      
      1: - Ping and resolve name of remote computer
           PASS - Server found
                - Protocol Address:             9.123.255.44
                - Protocol Address resolved:    IOALAB-X1
      
      2: - Connect to root\cimv2 WMI namespace
           FAIL - Was unable to connect. Diagnosis steps:
      
           - Have you run hvremote /add:user or hvremote /add:domain\user
             on IOALAB-X1 to grant access?
      
           - Are you sure the server name 'IOALAB-X1' is correct?
      
           - Did you use cmdkey to set credentials to the remote machine if needed?
      
           - Is DNS operating correctly and was IOALAB-X1 found?
             Look at previous tests to verify that the IP address
             matches the output of 'ipconfig /all' when run on
             IOALAB-X1. If you do not have a DNS infrastructure,
             edit \windows\system32\drivers\etc on win-f5an1p918fk
             to add an entry for IOALAB-X1.
      
      
      -------------------------------------------------------------------------------
      2 warnings or errors were found in the configuration. Review the
      detailed output above to determine whether you need to take further action.
      Summary is below.
      
      1: Cannot connect to root\cimv2 on IOALAB-X1
      2: Some tests were not run due to prior failures
      
      
      
      
    • Something I figured out: I'm using a Fritz!Box for DHCP and DNS. With cmdkey on the client first I used only the servername (SERVER) and get the same error.
      
      After using the full qualified name (SEVER.FRITZ.BOX) everything is running fine.
      
    • I had the same issue as David described in a Windows 8.1 server and Windows 8 client configuration. I had to remove both computers from the homegroup. As long they where in the homegroup, communication with Hyper-V launched as an administrator on the client was possible, but with a limited rights user not. When both computers where removed from the homegroup, I could connect with a limited rights user to the Hyper-V server computer.
  • Microsoft account is no problem, using a Homegroup is...
    2 Posts | Last post December 14, 2014
    • Thanks for this script John. I finally succeeded in getting vmconnect to work using Windows 8.1 for both client and the Hyper-V server. Client is using a Microsoft account. My final problem was that I had turned on Homegroup sharing in the past. After turning that off on both client and server, the list of VMs appeared in the vmconnect drop down. :-)
      
      Of course you have to use CMDKEY to store the server credentials.
      
      Peter
    • Great somebody has finally identified the issue. Now let's hope MS is going to fix it.
  • Windows 10
    1 Posts | Last post November 21, 2014
    • Hi John
      
      thanks for the great efforts.
      
      any hope you'll release a version that support Windows 10?
      
      thanks
  • Server Windows server 2012 client Windwos 8.1
    8 Posts | Last post May 15, 2014
    • hello, 
      
      I am running server on Windows 2012. My client windows 8.1 with Microsoft Account. Everything is working fine with Local OS account at Windows 8. 
      When i switch to Microsoft Account from Local Account Client server authentication is not working. 
      
      Any help ?
      
      regards
       
    • As I put in the known issues, I have not had time to verify with Microsoft Accounts on the client. In theory, if you treat the client as workgroup talking to the relevant server domain/workgroup-ness using the 10-second guide and ensure you use cmdkey on the client machine, it should work. LMK if that helps.
      Cheers,
      John.
    • Has there been any updates on allowing Microsoft Accounts to work using this tool?  Like Exchange Guy, things work fine when using a local account on the client, but not Microsoft accounts.  Thanks for your help.
    • I personally haven't tried. I've had one report that following the cmdkey method I mentioned above does work.
    • Another case when Microsoft Accounts ain't working.
      
      On the server side /show /target:client_pc /mode:server completes ok. On the client side /show /target:server_pc fails on root/cimv2 step.
      
      Tried cmdkey on the client several times. Both client and server are Windows 8.1 Pro.
      
    • Didn't work for me either (bot client and server being Win 8.1 in the same workgroup). I think there's a slight chance of the authentication conflicting with the HomeGroup mechanism. When tried "cmdkey /add /server:ZBIG-SERVER /user:ZBIG-SERVER\Zbigniew" on the client, I've noticed it replaces the default ZBIG-SERVER\HomeGroupUser$ entry. HomeGroup file sharing, however, doesn't stop working and, after restart, the ZBIG-SERVER\HomeGroupUser$ credentials entry is back and the ZBIG-SERVER\Zbigniew is gone. This leads me to believe that the HomeGroup mechanism is somehow enforcing its configuration and undoing any manual changes.
    • Correction: I used "cmdkey /add:ZBIG-SERVER /user:ZBIG-SERVER\Zbigniew" command instead of the one quoted incorrectly (why no "Edit post" option?).
    • I just figured out than when I change line 4621 from
      
      set oWbemServices=oSWbemLocator.ConnectServer(szRemoteServer,szNameSpace)
      
      to
      
      oWbemServices=oSWbemLocator.ConnectServer(szRemoteServer,szNameSpace,"SERVER\Username","password")
      
      then hvremote succeds on the client side. "Username" is the same for client and server. Unfortunately, I am unable to input the credentials anywhere in Hyper-V management console
  • "Async notification query to root\virtualization\v2 WMI namespace" not working
    8 Posts | Last post May 12, 2014
    • Hello John,
      
      I can't get this working using hvremote 1.0.8. I have a Windows Server 2012 R2 Standard Computer with Hyper-V Role installed (workgroup) and the client is a Windows 8.1 x64 Computer (domain). 
      When I try "hvremote /mode:client /show /target:SERVER" on the client it says:
      --
      8: - Async notification query to root\virtualization\v2 WMI namespace
           FAIL - Notification query failed Der RPC-Server ist nicht verfügbar.
      
      There may be a DNS issue and the server cannot locate this machine.
      You should check this by performing a ping test from the server to
      this machine verifying that the IP address the server is trying to
      reach matches the IP address of this machine shown in the output above.
      Note that it does not matter if the ping succeeds or fails, just that
      the IP address is correct.
      
      --
      
      Anyway the DNS works, I can ping and resolve the name of the client on the server side and vice-versa. ANON DCOM is granted, credentials for the server are stored. Any ideas what to try next?
    • Can you post the output of hvremote /show /target:otherboxname from both boxes?
    • Hello John,
      I am having the same problem. When I run hvremote /show /target:CLIENTPCNAME from the server, everything is OK, except IPv6 tracing (does IPv6 has to be enabled??)
      
      Regards,
      Manu
    • Nucom I had that problem first, too, but enabling IPv6 didn't help.
      John here are the results. I removed my Microsoft Account from the list of stored credentials, my User Account is not a MS account, I used credential for Apps in Windows store, I guess that wont affect this.
      I can't attach all the information in this post, so I put those hvremote outputs on my onedrive: 
      http://1drv.ms/1gaJQtq
      
    • Sorry. Correct link: http://1drv.ms/1gaK0Bb
    • Andreas - curious, I can't spot anything obviously wrong. Is it possible there is IPsec policy being applied to the client machine to block inbound connections from a non-domain joined machine? Or you have a third party firewall installed on the client that could be blocking the inbound connection from the server during that async test which is failing?
      
      Nucom - no, you don't need IPv6. If it gets to the end of the client tests and it can make WMI queries and async notifications, everything is good and remote management should work.
    • No, there is no IPsec enforcement. I will try from a different client, later. 
    • I just realized, that I can use "%windir%\system32\vmconnect.exe" to connect to a VM on my Hyper-V host. I can remote control and even change the settings of a VM.
  • Explicitly adding a user/group in Windows 8.1 doesn't work
    2 Posts | Last post May 07, 2014
    • In my test this script didn't not work when explicitly adding a user or group. Only works when add a user in the Hyper-v Administrator group.
      
      cscript hvremote.wsf /add:domain\user - WORKS
      cscript hvremote.wsf /add:domain\user /explicit - DOESN'T WORK
      
      All the test from client and server had passed. still can't access
      
      We have Server 2012 R2 domain controller. However, the Hyper-v is installed in one of the workstation, trying to access from another workstation with a non-admin user.
      
      Any help?
      
      thanks
    • Can you post the full output when using /explicit to diagnose that bit.
      
      For the failing case, it should not matter if Hyper-V the role is installed. Can you post the output of hvremote /show /target:otherboxname from the client and server machines. Note that on the client you may need to add /mode:client as the feature is enabled.
  • Domain trouble.
    2 Posts | Last post May 07, 2014
    • When entering the domain, let's say its name.local it gives me, "Error /add: a non qualified domain name must be supplied. eg /add:domain\user, not /add:domain.com\user. 
    • If the domain short name (eg 'contoso' in 'contoso.com') contains a period, the code will detect this. You can remove this bit of code from the script to get around it. I believe that the use of a full stop in a domain short name isn't recommended and hasn't been for some time.
      
                  if not(gbComputerIsWorkgroup) Then
                      if instr(gszServerOpAddOrRemoveDomainName,".") then
                          Usage "ERROR: /add: A non qualified domain name must be supplied." & vbcrlf & _
                                "             eg /add:domain\user, not /add:domain.com\user"
                          wscript.quit
                      end if
                  end if
  • Win7SP1(WrkGroup) > Managing > Win8.0(DomainMmbr)-Hyper-V
    2 Posts | Last post April 09, 2014
    • Is this possible?
      
      CLIENT: Win7x64Ult.SP1 (WorkGroup member only)
      SERVER: Hyper-V on Win8.0(Enterprise) Domain Member
      
      These are listed in the "Supported" Servers/Clients, but everywhere I read (including other utilities/webpages), it always references the REVERSE ENVIRONMENT (where the server is workgroup only).
      
      Thank you,
      Paul
      
      
      
    • See the 10-second guide on the description page. However, note that managing from a downlevel client is not recommended (some features may not be manageable). Windows 7 managing Windows 8.1 though is not possible at all.
21 - 30 of 41 Items